Latest features of WordPress 5.2 CMS along with some errors

The current version of WordPress 5.2 is now available for download. It is released on May 7, 2019, it is known as Jaco named after the revolutionary jazz bass guitarist Jaco Pastorius.

Wordpress 5.2

The new release comes with lots of new and exciting features, the biggest out of them is the new Site Health check tool. This tool is to educate users, as well as to provide developers with some important information that they need. There are dozens of more improvements that include PHP error protection (minimum white screens of death), current and fresh dash icons and emojis, a few block editor improvements, and accessibility updates.

WordPress runs smoothly most of the time, but if something goes wrong only developers could fix the issue in many cases. There is a lot of exciting WordPress features that are loved by most of the users. But in some cases, WordPress encounter certain errors. To deal with that error, you need expert advice. Contact the experts to get your problem solved.

The new features of WordPress 5.2

WordPress 5.1 introduced Site Health, a collection of features mainly focused on security and speed. WordPress 5.2 adds on the suite with Site Health Check, which builds two new pages to help rectify common configuration issues. Site Health Check also builds a space where developers can incorporate debugging information for site maintainers.

Next is PHP Error Protection, an administrator-focused update that allows you to safely fix or manage fatal errors without taking developer time. PHP Error Protection includes better handling of the “white screen of death.” It also proposes a way to enter recovery mode, which stops error-causing plugins or themes.

Apart from this, WordPress 5.2 brings accessibility updates to enhance contextual awareness and keyboard navigation flow for those who use screen readers and other operative technologies. In addition to that, there are also 13 new dashboard icons and plugin compatibility checks — WordPress will now automatically decide if your site’s version of PHP is compatible with installed plugins or not. If the plugin needs a higher version of PHP than your site currently uses, WordPress will not let you start it.

Some errors of the new version of WordPress

1. A plugin may be paused because another plugin used a lot of memory. When a site’s memory extent is reached, the plugin that is running at the time can be paused, even if it is not using much memory. That might cause security issues, or may just be complex for the admin since the paused plugin(s) aren’t accordingly the cause of the issue.

2. Local File additional exposers in any plugin/theme will give the attacker the ability to pause many plugins at will. When any plugin/theme is vulnerable to “Local File Inclusion (LFI)”, an attacker often cannot utilise that to apply changes to the site, but if plugins can be stopped by WP 5.1 for again declaring an existing class, an attacker can select specific plugins to pause, even if those plugins are not safe.

3. It might be possible that max execution time has the same problem as the memory limit. On a shared host that is working slowly, or any server undergoing heavy load (including during the intentional DoS or brute force attacks), many of the requests may lead to timeouts, which may occur in random plugins code or the theme’s code.

So these are some of the features and errors of the new version of WordPress. If you need any assistance, then refer WordPress support where experts will help you to sort out your problems with the best solution in no time.

Summary: The latest WordPress 5.2 has many unique features and may face some errors. Encounter that error with the help of WordPress support.

Leave a Comment

Your email address will not be published. Required fields are marked *